Wireshark envía un StartupItem
que hace exactamente eso; sin embargo, la API de StartupItems está en desuso:
The SystemStarter utility is deprecated. System services should instead
be described by a launchd.plist(5). See launchd(8) for more details.
The launchd utility is available on Mac OS X 10.4 and later.
In earlier versions of Mac OS X, the SystemStarter utility is used to
start, stop, and restart the system services which are described in the
/Library/StartupItems/ and /System/Library/StartupItems/ paths.
Entonces, ya que estás pidiendo "la solución más elegante", sería un demonio de lanzamiento.
No he probado el siguiente código, pero debería ser más o menos correcto.
Crea un archivo /Library/LaunchDaemons/com.stackexchange.apple.bpf-helper.plist
:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Label</key>
<string>com.stackexchange.apple.bpf-helper</string>
<key>ProgramArguments</key>
<array>
<string>/Library/PrivilegedHelperTools/com.stackexchange.apple.bpf-helper.sh</string>
</array>
</dict>
</plist>
Y un archivo /Library/PrivilegedHelperTools/com.stackexchange.apple.bpf-helper.sh
:
#!/bin/sh
chgrp admin /dev/bpf*
chmod g+rw /dev/bpf*
Ambos deben ser propiedad de root:wheel
. El primero debe ser 644; el segundo 755 (600 y 700, respectivamente, probablemente también lo hará).
Puedes usar launchctl load -w /Library/LaunchDaemons/com.stackexchange.apple.bpf-helper.plist
para intentarlo sin reiniciar.