zsh temas cargados pero no funcionan

7

Configuré el tema en el archivo .zshrc :

ZSH_THEME="random"

Y cuando se abre una nueva pestaña, muestra que se ha cargado un nuevo tema:

[oh-my-zsh] Random theme '/Users/maks/.oh-my-zsh/themes/gozilla.zsh-theme' loaded...
mac

Pero en realidad no veo ningún cambio en el tema.

Nueva pestaña de nuevo

[oh-my-zsh] Random theme '/Users/maks/.oh-my-zsh/themes/crunch.zsh-theme' loaded

y otra vez:

[oh-my-zsh] Random theme '/Users/maks/.oh-my-zsh/themes/tjkirch.zsh-theme' loaded...

Pero sigo viendo el mismo tema. Ya he recargado el mac, pero no hay resultados. El mismo resultado en Terminal y iTerm

Actualizar:

No todos los temas fallan. Éste funciona: trapd00r pero con error: prompt_jnrowe_precmd:3: command not found: zsh_path . Otros no funcionan.

Actualización 2: El tema linuxonly también funciona:

[oh-my-zsh] Random theme '/Users/maks/.oh-my-zsh/themes/linuxonly.zsh-theme' loaded...
mac
[email protected]:s047->/Users/maks (0)

pero con error:

Can't open perl script "/home/scp1/bin/foopath": No such file or directory
    
pregunta Maxim Yefremov 17.11.2013 - 04:51

2 respuestas

6

¿Tiene una PS1 personalizada que está anulando la solicitud del tema que ha seleccionado?

  1. ¿Comprueba que no tiene líneas adicionales en ~ / .zshrc más allá del valor predeterminado?

    1. Copia de seguridad de su .zshrc
    2. Eliminar todas las líneas más allá de export PATH=$PATH:/
    3. vuelve a cargar tu terminal
  2. ¿Tienes algún complemento que esté jugando con las cosas?

    • Revisa ~ / .oh-my-zsh / custom / plugins / para cualquier complemento adicional.
    • Elimine todos sus complementos de su ~ / .zshrc y vuelva a cargar su Terminal.
  3. ¿Comprueba que no tiene líneas adicionales en su ~ / .zprofile?

    mv ~/.zprofile ~/.zprofile-bak
    

    … y vuelve a cargar tu terminal. (Vuelva a colocar con mv ~/.zprofile-bak ~/.zprofile )

Nota: trapd00r y linuxonly muestran los mismos errores para mí

    
respondido por el grg 02.12.2013 - 20:03
4

¿Tiene su perfil de iTerm configurado para reportar 256 colores?

    
respondido por el Bert 17.11.2013 - 17:50

Lea otras preguntas en las etiquetas